MotionBox » Forums » Bug on Archlinux, libdouble-conversion
Ian
5 posts
#16928 Bug on Archlinux, libdouble-conversion
3 months, 1 week ago Edited by Ian on Dec. 7, 2018, 11:05 p.m. Reason: Initial post

Hey,

I just downloaded Motionbox and tried running it, using the start.sh script. Then I got an error that libdouble-conversion.so.1 was missing.

I fixed it by making a symbolic link in /usr/lib from libdouble-conversion.so.1 to libdouble-conversion.so.3.0.0

bunjee
Benjamin Arnaud
75 posts / 1 project

hacker for the society of sharing.

#16935 Bug on Archlinux, libdouble-conversion
3 months, 1 week ago

Hi Ian,

Thank you for pointing that out. The build is tested on Ubuntu but I'm glad you made it run on Arch.
krixano
Christian Seibold
11 posts / 1 project

Going to BriarCliff University as a Computer Science major. I like to read, write poetry, and learn. I mainly use C and Javascript.

#17011 Bug on Archlinux, libdouble-conversion
3 months ago

On Solus, the software center doesn't have libdouble-conversion (version 2 seems to be the one MotionBox uses), so you have to manually download and build it and move the resulting .so into the MotionBox folder (I tried installing it to the system, but that didn't work, motionbox still couldn't find it).

None