MotionBox»Forums
Benjamin Arnaud
74 posts / 1 project
hacker for the society of sharing.
MotionBox is running on Linux
Edited by Benjamin Arnaud on


Greetings folks,

It's been a busy day and I pushed a bunch of linux related code.

As of today I'm happy to announce that MotionBox is running on linux \o/.
The whole GUI is functional and the video playback is working... At least that's the case on ubuntu :-D.
There's still a few glitches related to drag & drop, window positioning and pictures. I'll have to double check on Arch linux.

I'll just run a few tests and push the very first linux release later next week.

Big thank to miotatsu for his help on the Sky kit linux build !

P34C3.
Allen Webster
473 posts / 2 projects
Heyo
MotionBox is running on Linux
AWESOME! I'll absolutely be hitting that download sometime soon.
Jeremiah Goerdt
209 posts / 2 projects
Programmer, Linux apologist, and not-so-wiseman.
MotionBox is running on Linux
I'm pretty excited to get my hands on your creation. Is it ready for us to run over to your GitHub and give it a go, or should we all wait for an official Linux release?
Benjamin Arnaud
74 posts / 1 project
hacker for the society of sharing.
MotionBox is running on Linux
Edited by Benjamin Arnaud on
@Jeremiah: Well it's still a bit rough around the edges. I'd say wait the end of the week.

I'm currently looking for a way to deliver it as a standalone archive.
Jeremiah Goerdt
209 posts / 2 projects
Programmer, Linux apologist, and not-so-wiseman.
MotionBox is running on Linux
Any news on the Linux front?
Jeremiah Goerdt
209 posts / 2 projects
Programmer, Linux apologist, and not-so-wiseman.
MotionBox is running on Linux
Jeroen informed me that I'm silly and didn't see the Linux download link. I downloaded it and got it running. I had to install 'nas' to get the audio lib that it was complaining about, but then it fired up without a problem. Videos are playing just fine.

Thanks!
Jeroen van Rijn
248 posts / 1 project
A big ball of Wibbly-Wobbly, Timey-Wimey _stuff_
MotionBox is running on Linux
CaptainKraft
Jeroen informed me that I'm silly and didn't see the Linux download link. I downloaded it and got it running. I had to install 'nas' to get the audio lib that it was complaining about, but then it fired up without a problem. Videos are playing just fine.

Thanks!


I didn't say _that_ exactly. I fixed the uploads and some of bunjees uploads had made it to the server, just not in the right place, so I reuploaded them after the fact and presto, one Linux version.
Benjamin Arnaud
74 posts / 1 project
hacker for the society of sharing.
MotionBox is running on Linux
Edited by Benjamin Arnaud on
CaptainKraft
Jeroen informed me that I'm silly and didn't see the Linux download link. I downloaded it and got it running. I had to install 'nas' to get the audio lib that it was complaining about, but then it fired up without a problem. Videos are playing just fine.

Thanks!

Greetings Jeremiah, Thank you for asking about it though !
The HMN 1.1.2 linux archive is quite dated indeed. I'll update that soon.

I've completed 1.2.0 for both Windows and Linux, you can get it here: http://omega.gg/MotionBox/get.
I didnt take the time to communicate about it yet. But when this happens it will certainly be on the HMN.
Benjamin Arnaud
74 posts / 1 project
hacker for the society of sharing.
MotionBox is running on Linux
Edited by Benjamin Arnaud on
Kelimion
I didn't say _that_ exactly. I fixed the uploads and some of bunjees uploads had made it to the server, just not in the right place, so I reuploaded them after the fact and presto, one Linux version.

Congratulations for fixing the uploads Jeroen.

PS: That new site layout is really cool. Kudos to the web team.
Benjamin Arnaud
74 posts / 1 project
hacker for the society of sharing.
MotionBox is running on Linux
CaptainKraft
I had to install 'nas' to get the audio lib that it was complaining about, but then it fired up without a problem.

Let me know if this happens with 1.2.0. Also, what distribution are you using ?
Jeremiah Goerdt
209 posts / 2 projects
Programmer, Linux apologist, and not-so-wiseman.
MotionBox is running on Linux
bunjee
CaptainKraft
I had to install 'nas' to get the audio lib that it was complaining about, but then it fired up without a problem.

Let me know if this happens with 1.2.0. Also, what distribution are you using ?


I'm in Arch Linux and had to install the 'nas' package from the AUR
Benjamin Arnaud
74 posts / 1 project
hacker for the society of sharing.
MotionBox is running on Linux
Edited by Benjamin Arnaud on
CaptainKraft
I'm in Arch Linux and had to install the 'nas' package from the AUR

That was the case for 1.1.2 archive. The 1.2.0 comes with libaudio2.
Jeremiah Goerdt
209 posts / 2 projects
Programmer, Linux apologist, and not-so-wiseman.
MotionBox is running on Linux
Sorry, I didn't have a chance to try the new version at the time. Seems to work great.
66 posts
None
MotionBox is running on Linux
Hello there.
On ubuntu 16.04 with a tiling window manager.
It worked for me out of the box.

It's a really really awesome tool !
Many thanks for sharing !
Jeremiah Goerdt
209 posts / 2 projects
Programmer, Linux apologist, and not-so-wiseman.
MotionBox is running on Linux
It turns out I am having some issues.

1
2
3
4
5
6
7
Loading Source https://www.youtube.com/watch?v=LsBrmSNBH5g
Get http://www.youtube.com/get_video_info?video_id=LsBrmSNBH5g&el=detailpage
ENCRYPTED
Get https://www.youtube.com/embed/LsBrmSNBH5g
Get /yts/jsbin/player-en_US-vflp0EuAP/base.js
WLoaderNetworkPrivate::onFinished: Get failed /yts/jsbin/player-en_US-vflp0EuAP/base.js code 301. Protocol "" is unknown
WControllerMediaPrivate::onLoaded: Failed to load media /yts/jsbin/player-en_US-vflp0EuAP/base.js.


Lots of videos just won't play for me. Here is some output that I get when that happens.